Ecco una configurazione ospf  d’esempio per quagga:

!
! Zebra configuration saved from vty
!
hostname ospfgw01
password mypassword
enable password mypassword
log stdout
!
log file /var/log/quagga/quagga-ospf.log
debug ospf nsm
debug ospf zebra
!
!
interface eth0
!
interface eth1
ip ospf cost 1
ip ospf hello-interval 3
ip ospf dead-interval 10
!
interface eth2
ip ospf authentication
ip ospf authentication-key mypass
ip ospf cost 1
ip ospf hello-interval 3
ip ospf dead-interval 10
!
interface eth3
ip ospf authentication
ip ospf authentication-key mypass
ip ospf cost 1
ip ospf hello-interval 3
ip ospf dead-interval 10
!
interface eth4
!
interface eth5
!
interface eth6
!
interface eth7
ip ospf cost 300
!
interface lo
!
router ospf
ospf router-id 1.1.1.3
log-adjacency-changes
redistribute kernel
redistribute static
passive-interface eth0
passive-interface eth7
network 1.1.1.0/24 area 0.0.0.1
network 2.2.2.0/24 area 0.0.0.0
network 3.3.3.0/24 area 0.0.0.0
network 4.4.4.8/29 area 0.0.0.1
area 0.0.0.0 authentication
!
line vty
!
~

Per poter attivare il routing ospf su uno switch hp 5400zl oppure acquistare e installare la licenza premium.

Una configurazione di esempio e’ la seguente:

ip router-id 10.96.0.1
.1 range 10.96.0.0 255.255.255.0 type summary
... ip routing ... ip router-id 1.1.1.1 .... router ospf area 0.0.0.1 range 1.1.1.0 255.255.255.0 type summary area backbone redistribute connected redistribute static restrict subnet 255.255.255.0 exit ... vlan 10 ip ospf 1.1.1.1 area 0.0.0.1 ip ospf 1.1.1.1 dead-interval 10 ip ospf 1.1.1.1 hello-interval 3 exit
...

Autenticazione OSPF

13 Apr
2010

Ospf supporta la possibilità di autenticare i propri pacchetti in modo da decidere quale router può partecipare allo scambio di messaggi LSA.

Normalmente, di default, i router usano “una null autenthication”

I metodi di autenticazione supportati da Ospf  sono:

  • simple password
  • md5

Spesso alcune semplici sviste o malconfigurazioni possono portare a un troubleshooting lungo e complesso.

Nel caso in cui due router direttamente connessi non riescano a parlare via ospf (scambio lsa) e se il traffico multicast arriva correttamente se viene analizzato il flusso di dati che i due router si scambiano, molto probabilmente la non visibilità del vicino e’ causata dall’errata impostazione dei timer (dead interval e hello interval).

Il problema da risolvere e’ il seguente: dati N routers su una rete locale, e’ possibile stabilire che esistono N*(N-1)/2 adiacenze, tali che ogni router deve quindi inviare N-1 messaggi verso gli altri routers vicini piu’ uno verso la rete (stub network) per un totale di N*N messaggi.

OSPF prova a ridurre a solo N adiacenze designando uno dei router (Designed Router o DR) in modo tale che i rimanenti routers stabiliscano adiacenze solo con il router designato.

Il primo passo e’ eleggere il router designato. Questa elezione e’ incorporata nella procedura “Hello”. Dopo l’elezione, gli altri routers porteranno le proprie adiacenze verso il router designato o sincronizzeranno il proprio database.

La presenza del router designato serve inoltre per :

Ridurre il numero dei record di link state nel database, in quanto la rete broadcast potra’ essere rappresentata da un set di links tra i routers ed un nodo virtuale.

Semplificare la procedura di flooding, quando un router deve inviare una LSA (Link State Advertisment), la trasmette solo al router designato, utilizzando l’indirizzo multicast 224.0.0.6. Se si tratta di una nuova LSA, il router designato diffondera’ il link state a tutte le proprie interfacce e alla rete utilizzando l’indirizzo multicast 224.0.0.5.

Tuttavia, se il DR cade, tutti i routers apparirebbero disconnessi dalla rete, sebbene questa sia, a tutti gli effetti, ancora operativa. Risulta quindi indispensabile eleggere al piu’ presto un nuovo DR. OSPF ovvia questo problema, con l’elezione di un “Backup Designed Router o BPR”, contemporaneamente all’elezione del DR.

Tutti i routers creeranno quindi le proprie adiacenze con entrambi i routers DR e BDR; se il DR cade, l’anomalia verra’ immediatamente rilevata dal protocollo Hello, il BDR diventera’ immediatamente DR ed un nuovo BDR verra’ eletto. Tutti i routers stabiliranno un adiacenza con il nuovo BDR.

top